summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Colomar <alx.manpages@gmail.com>2022-08-01 01:57:20 +0200
committerAlejandro Colomar <alx.manpages@gmail.com>2022-08-01 14:22:19 +0200
commitc3b57e05e02c561cd23cd5128373f37e1befd45f (patch)
tree474fc29a7c0219a4c43bb1d7561699f49c8186f1
parent2f636827a30ff2eb2251794e16060f627c079e5a (diff)
lib/pkg/debian/...: Add debian packagingdebian
Signed-off-by: Alejandro Colomar <alx.manpages@gmail.com>
-rw-r--r--lib/pkg/debian/changelog1
-rw-r--r--lib/pkg/debian/control20
-rw-r--r--lib/pkg/debian/copyright20
-rwxr-xr-xlib/pkg/debian/rules75
4 files changed, 116 insertions, 0 deletions
diff --git a/lib/pkg/debian/changelog b/lib/pkg/debian/changelog
new file mode 100644
index 000000000..ed2a80dee
--- /dev/null
+++ b/lib/pkg/debian/changelog
@@ -0,0 +1 @@
+man-pages (0version) UNRELEASED; urgency=medium
diff --git a/lib/pkg/debian/control b/lib/pkg/debian/control
new file mode 100644
index 000000000..449385803
--- /dev/null
+++ b/lib/pkg/debian/control
@@ -0,0 +1,20 @@
+Source: man-pages
+Section: doc
+Priority: standard
+Maintainer: Alejandro Colomar <alx.manpages@gmail.com>
+Rules-Requires-Root: no
+Build-Depends:
+ debhelper-compat (= 13),
+Standards-Version: 4.6.1
+Homepage: https://www.kernel.org/doc/man-pages/
+Vcs-Browser: https://git.kernel.org/pub/scm/docs/man-pages/man-pages.git
+Vcs-Git: git://git.kernel.org/pub/scm/docs/man-pages/man-pages.git
+
+Package: man-pages
+Architecture: all
+Multi-Arch: foreign
+Depends:
+Suggests:
+ man-browser,
+Description: Manual pages about using a GNU/Linux system
+ This package contains Linux man pages for chapters 1 through 8.
diff --git a/lib/pkg/debian/copyright b/lib/pkg/debian/copyright
new file mode 100644
index 000000000..bd186b2e3
--- /dev/null
+++ b/lib/pkg/debian/copyright
@@ -0,0 +1,20 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Source: https://www.kernel.org/pub/linux/docs/man-pages/
+Upstream-Name: man-pages
+Upstream-Contact:
+ Alejandro Colomar <alx.manpages@gmail.com>,
+ linux-man@vger.kernel.org
+
+Files:
+ *
+Copyright:
+ All Linux man-pages authors and contributors.
+License:
+ Several; the pages are all freely distributable as long as nroff
+ source is provided
+
+Files:
+ debian/*
+Copyright:
+ 2022 Alejandro Colomar <alx.manpages@gmail.com>
+License: GPL-3.0-or-later
diff --git a/lib/pkg/debian/rules b/lib/pkg/debian/rules
new file mode 100755
index 000000000..8e80f9c6c
--- /dev/null
+++ b/lib/pkg/debian/rules
@@ -0,0 +1,75 @@
+#!/usr/bin/make -f
+
+
+srcdir := ../..
+debiandir := $(srcdir)/lib/pkg/debian
+builddir := $(srcdir)/tmp
+debbuilddir:= $(builddir)/debian
+DESTDIR := $(debbuilddir)/tmp
+PKGNAME := man-pages
+PKGVERSION := 0unknown
+prefix := /opt/local/$(PKGNAME)
+
+
+.PHONY: clean
+.PHONY: build
+.PHONY: build-arch
+.PHONY: build-indep
+.PHONY: install
+.PHONY: binary
+.PHONY: binary-arch
+.PHONY: binary-indep
+.PHONY: get-oring-source
+
+
+clean:
+ $(MAKE) -f $(srcdir)/Makefile clean srcdir=$(srcdir)
+
+build: build-arch build-indep
+ @:
+
+build-arch:
+ @:
+
+build-indep:
+ @:
+
+install:
+ rm -rf $(debbuilddir)
+ cp -rT $(debiandir) $(debbuilddir)
+ $(MAKE) -f $(srcdir)/Makefile install \
+ srcdir=$(srcdir) \
+ DESTDIR=$(DESTDIR) \
+ prefix=$(prefix) \
+ >/dev/null
+
+binary: binary-arch binary-indep
+ @:
+
+binary-arch: install
+ @:
+
+binary-indep: install
+ mkdir $(DESTDIR)/DEBIAN
+ dpkg-gencontrol \
+ -v$(PKGVERSION) \
+ -c$(debiandir)/control \
+ -l$(debiandir)/changelog \
+ -f$(debbuilddir)/files \
+ -P$(DESTDIR)
+ cd $(builddir) && dh_md5sums
+ dpkg-deb --root-owner-group -b $(DESTDIR) $(builddir)
+
+get-orig-source:
+ @:
+
+
+#########
+
+.PHONY: builddeb
+builddeb:
+
+
+# See debhelper(7) (uncomment to enable).
+# Output every command that modifies files on the build system.
+#export DH_VERBOSE = 1