summaryrefslogtreecommitdiffstats
path: root/lib/pkg/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'lib/pkg/debian/rules')
-rwxr-xr-xlib/pkg/debian/rules75
1 files changed, 75 insertions, 0 deletions
diff --git a/lib/pkg/debian/rules b/lib/pkg/debian/rules
new file mode 100755
index 000000000..8e80f9c6c
--- /dev/null
+++ b/lib/pkg/debian/rules
@@ -0,0 +1,75 @@
+#!/usr/bin/make -f
+
+
+srcdir := ../..
+debiandir := $(srcdir)/lib/pkg/debian
+builddir := $(srcdir)/tmp
+debbuilddir:= $(builddir)/debian
+DESTDIR := $(debbuilddir)/tmp
+PKGNAME := man-pages
+PKGVERSION := 0unknown
+prefix := /opt/local/$(PKGNAME)
+
+
+.PHONY: clean
+.PHONY: build
+.PHONY: build-arch
+.PHONY: build-indep
+.PHONY: install
+.PHONY: binary
+.PHONY: binary-arch
+.PHONY: binary-indep
+.PHONY: get-oring-source
+
+
+clean:
+ $(MAKE) -f $(srcdir)/Makefile clean srcdir=$(srcdir)
+
+build: build-arch build-indep
+ @:
+
+build-arch:
+ @:
+
+build-indep:
+ @:
+
+install:
+ rm -rf $(debbuilddir)
+ cp -rT $(debiandir) $(debbuilddir)
+ $(MAKE) -f $(srcdir)/Makefile install \
+ srcdir=$(srcdir) \
+ DESTDIR=$(DESTDIR) \
+ prefix=$(prefix) \
+ >/dev/null
+
+binary: binary-arch binary-indep
+ @:
+
+binary-arch: install
+ @:
+
+binary-indep: install
+ mkdir $(DESTDIR)/DEBIAN
+ dpkg-gencontrol \
+ -v$(PKGVERSION) \
+ -c$(debiandir)/control \
+ -l$(debiandir)/changelog \
+ -f$(debbuilddir)/files \
+ -P$(DESTDIR)
+ cd $(builddir) && dh_md5sums
+ dpkg-deb --root-owner-group -b $(DESTDIR) $(builddir)
+
+get-orig-source:
+ @:
+
+
+#########
+
+.PHONY: builddeb
+builddeb:
+
+
+# See debhelper(7) (uncomment to enable).
+# Output every command that modifies files on the build system.
+#export DH_VERBOSE = 1