summaryrefslogtreecommitdiffstats
path: root/libcxx/test/std/utilities/format/format.formatter/format.formatter.spec/types.compile.pass.cpp
diff options
context:
space:
mode:
Diffstat (limited to 'libcxx/test/std/utilities/format/format.formatter/format.formatter.spec/types.compile.pass.cpp')
-rw-r--r--libcxx/test/std/utilities/format/format.formatter/format.formatter.spec/types.compile.pass.cpp8
1 files changed, 4 insertions, 4 deletions
diff --git a/libcxx/test/std/utilities/format/format.formatter/format.formatter.spec/types.compile.pass.cpp b/libcxx/test/std/utilities/format/format.formatter/format.formatter.spec/types.compile.pass.cpp
index fcddf832df2c..4db4f017e5ac 100644
--- a/libcxx/test/std/utilities/format/format.formatter/format.formatter.spec/types.compile.pass.cpp
+++ b/libcxx/test/std/utilities/format/format.formatter/format.formatter.spec/types.compile.pass.cpp
@@ -36,9 +36,6 @@
#include <set>
#include <stack>
#include <span>
-#ifndef _LIBCPP_HAS_NO_THREADS
-# include <thread>
-#endif
#include <tuple>
#include <type_traits>
#include <unordered_map>
@@ -51,6 +48,9 @@
#ifndef TEST_HAS_NO_LOCALIZATION
# include <regex>
#endif
+#ifndef TEST_HAS_NO_THREADS
+# include <thread>
+#endif
// Validate default template argument.
static_assert(std::same_as<std::formatter<int>, std::formatter<int, char>>);
@@ -217,7 +217,7 @@ void test_P1636() {
#ifndef TEST_HAS_NO_LOCALIZATION
assert_formatter_is_disabled<std::sub_match<CharT*>, CharT>();
#endif
-#ifndef _LIBCPP_HAS_NO_THREADS
+#ifndef TEST_HAS_NO_THREADS
assert_formatter_is_disabled<std::thread::id, CharT>();
#endif
assert_formatter_is_disabled<std::unique_ptr<int>, CharT>();