summaryrefslogtreecommitdiffstats
path: root/libc/src/__support/CPP/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libc/src/__support/CPP/CMakeLists.txt')
-rw-r--r--libc/src/__support/CPP/CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/libc/src/__support/CPP/CMakeLists.txt b/libc/src/__support/CPP/CMakeLists.txt
index 8a61fc76922f..b591734a6b6f 100644
--- a/libc/src/__support/CPP/CMakeLists.txt
+++ b/libc/src/__support/CPP/CMakeLists.txt
@@ -12,12 +12,10 @@ add_header_library(
TypeTraits.h
)
-if(LLVM_LIBC_INCLUDE_SCUDO OR NOT LLVM_LIBC_FULL_BUILD)
- add_header_library(
- vector
- HDRS
- vector.h
- DEPENDS
- libc.include.stdlib
- )
-endif()
+add_header_library(
+ vector
+ HDRS
+ vector.h
+ DEPENDS
+ libc.include.stdlib
+)