summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 923b4d9..0a0d683 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,9 +68,9 @@ endif()
set(LLVM_LINK_COMPONENTS
Option
Support
- X86AsmParser
- X86Desc
- X86Info
+ AllTargetsAsmParsers
+ AllTargetsDescs
+ AllTargetsInfos
)
add_llvm_executable(include-what-you-use
@@ -110,8 +110,8 @@ if (MSVC)
-D_HAS_EXCEPTIONS=0
)
- # Enable bigobj support and sane C++ exception semantics.
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /bigobj /EHsc")
+ # Enable bigobj support
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /bigobj")
endif()
# Link dynamically or statically depending on user preference.