summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSylvestre Ledru <sylvestre@mozilla.com>2018-12-27 12:12:25 +0100
committerSylvestre Ledru <sylvestre@mozilla.com>2018-12-27 12:12:25 +0100
commitd653ec3909d00d8f65b1765ad228f45c00e644a1 (patch)
treef0fabf1d0c2697c7a02070aca3e8793858258975
parent4ae86c161eff730d6b2f0555bd0516a5e3c9f4ed (diff)
chrpath -d was enough to be able to remove my bad workaround7.0-2
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules7
3 files changed, 10 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 944c739..36f812e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+iwyu (7.0-2) unstable; urgency=medium
+
+ * chrpath -d was enough to be able to remove my bad workaround
+
+ -- Sylvestre Ledru <sylvestre@debian.org> Thu, 27 Dec 2018 12:12:15 +0100
+
iwyu (7.0-1) unstable; urgency=medium
* New upstream release
diff --git a/debian/control b/debian/control
index 1155891..2629f0d 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: LLVM Packaging Team <pkg-llvm-team@lists.alioth.debian.org>
Uploaders: Sylvestre Ledru <sylvestre@debian.org>
Build-Depends: debhelper (>= 10.0.0), cmake, clang-7, libclang-7-dev,
- llvm-7-dev, help2man, libncurses5-dev, zlib1g-dev
+ llvm-7-dev, help2man, libncurses5-dev, zlib1g-dev, chrpath
Build-Conflicts: llvm-5.0-dev, llvm-6.0-dev
Standards-Version: 4.2.1
Homepage: http://include-what-you-use.org/
diff --git a/debian/rules b/debian/rules
index ab223a7..d2234f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,6 +16,7 @@ endif
%:
dh $@ --buildsystem=cmake --builddirectory=$(TARGET_BUILD)
+
override_dh_auto_configure:
dh_auto_configure -- -DCMAKE_CXX_FLAGS="$(ADDITIONAL_CXX_FLAGS)" -DLLVM_PATH=/usr/lib/llvm-7/ -DCMAKE_PREFIX_PATH=/usr/lib/llvm-7/
@@ -25,6 +26,8 @@ override_dh_auto_build:
help2man --no-info --version-string "$(VERSION)" -n "Analyze #includes in C and C++ source files" $(TARGET_BUILD)/bin/include-what-you-use > $(TARGET_BUILD)/include-what-you-use.1
cd $(TARGET_BUILD) && ln -s include-what-you-use.1 iwyu.1 && \
cp ../fix_includes.py fix_include
+ chrpath -d $(TARGET_BUILD)/bin/include-what-you-use
+
override_dh_auto_install:
dh_auto_install
@@ -36,7 +39,3 @@ override_dh_auto_install:
override_dh_auto_clean:
rm -rf $(TARGET_BUILD)
-override_dh_shlibdeps:
-# not sure why this is failing
- dh_shlibdeps -- --ignore-missing-info
- chrpath -d debian/iwyu/usr/bin/include-what-you-use