summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Colomar <alx.manpages@gmail.com>2022-07-30 20:31:40 +0200
committerAlejandro Colomar <alx.manpages@gmail.com>2022-08-01 14:19:21 +0200
commite67acee2089dd957d629b0e6faaa796e356b05dd (patch)
tree2bc32c0f7cd65638270491e3ea010974f91a1fa8
parente7ba4bd4fb0293fc5097a0c94245fc4b83b46965 (diff)
dist.mk: Create tarballs with a top-level directory
Need to use a trick with sed(1) to avoid tar(1) modifying the symlinks. Signed-off-by: Alejandro Colomar <alx.manpages@gmail.com>
-rw-r--r--lib/dist.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/dist.mk b/lib/dist.mk
index 7798d59a1..570c81f2c 100644
--- a/lib/dist.mk
+++ b/lib/dist.mk
@@ -21,7 +21,8 @@ $(DISTFILE): $(shell git ls-files 2>/dev/null) | $$(@D)/.
$(info TAR $@)
tar cf $@ -T /dev/null
git ls-files \
- | xargs tar rf $@
+ | sed 's,^,./,' \
+ | xargs tar rf $@ -C $(srcdir) --transform 's,^\.,$(DISTNAME),'
$(DISTFILE).gz: %.gz: % | $$(@D)/.
$(info GZIP $@)