summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Colomar <alx@kernel.org>2023-08-03 20:35:39 +0200
committerDr. Tobias Quathamer <toddy@debian.org>2023-09-11 22:03:10 +0200
commitd9460230c0cec275e532ef660aafc8b9d51f17dc (patch)
tree9ec6049c3e6d0535ecf440d95cfccfb7c0e0fa12
parent2f80998a749dadf0d4ac1022609b1fff52180ec2 (diff)
d/rules: override_dh_auto_test: Improve readability of logs
Run make(1) twice consecutively. The first run makes everything that won't fail, as fast as possible, and hiding any errors. The second run will fail at the first target, because only failing targets are remaining. Since it doesn't run with -j, the output isn't mixed with other output. Signed-off-by: Alejandro Colomar <alx@kernel.org>
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 4bde32be7..c93bf7250 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,7 +18,8 @@ override_dh_auto_test:
touch .tmp/man/man7/bpf-helpers.7.lint-man.mandoc.touch
touch .tmp/man/man7/uri.7.lint-man.mandoc.touch
touch .tmp/man/man8/zic.8.lint-man.mandoc.touch
- make -j4 lint-man
+ make -kj4 lint-man >/dev/null 2>&1 || :
+ make lint-man
make -kj4 check >/dev/null 2>&1 || :
touch .tmp/man/man1/memusage.1.check-catman.touch
touch .tmp/man/man2/fanotify_init.2.cat.set
@@ -41,7 +42,8 @@ override_dh_auto_test:
touch .tmp/man/man8/tzselect.8.cat.set
touch .tmp/man/man8/zdump.8.cat.set
touch .tmp/man/man8/zic.8.cat.set
- make -j4 check
+ make -kj4 check >/dev/null 2>&1 || :
+ make check
override_dh_installchangelogs:
dh_installchangelogs Changes