summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Fouces <marcos@debian.org>2023-02-15 23:54:11 +0100
committerMarcos Fouces <marcos@debian.org>2023-02-15 23:54:11 +0100
commit5c2e1001e0e93be2ca0d110bc009c91001d5a314 (patch)
treeb59762ea45055ad7f943e8f371e8838dc55860f3
parent3cb782f6c05551582b568e6f913d05c9b8efe7b9 (diff)
Add support link handling in man3head directory.
-rw-r--r--debian/changelog2
-rw-r--r--debian/move_links_to_correct_package6
-rwxr-xr-xdebian/rules5
3 files changed, 8 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 45402aad4..cf0170f89 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ manpages (6.03-1) UNRELEASED; urgency=medium
* New upstream version 6.03
* Refresh patches.
+ * d/rules & d/move_links_to_correct_package: add support for
+ link handling in man3head directory.
-- Marcos Fouces <marcos@debian.org> Wed, 15 Feb 2023 17:45:03 +0100
diff --git a/debian/move_links_to_correct_package b/debian/move_links_to_correct_package
index 0ccfbf112..1503f48a7 100644
--- a/debian/move_links_to_correct_package
+++ b/debian/move_links_to_correct_package
@@ -53,9 +53,9 @@ for src_section in man*; do
dest_section=`echo "$destination" | sed -e "s/.*\(man.\).*/\1/"`
if [ "$dest_section" != "$src_section" ]; then
# The destination is in the package manpages
- if [ "$dest_section" != "man2" -a "$dest_section" != "man3" -a "$dest_section" != "man3type" -a "$dest_section" != "man3const" ]; then
+ if [ "$dest_section" != "man2" -a "$dest_section" != "man3" -a "$dest_section" != "man3type" -a "$dest_section" != "man3const" -a "$dest_section" != "man3head" ]; then
# Ensure the source link is not in package manpages-dev
- if [ "$src_section" = "man2" -o "$src_section" = "man3" -o "$src_section" = "man3type" -o "$src_section" = "man3const" ]; then
+ if [ "$src_section" = "man2" -o "$src_section" = "man3" -o "$src_section" = "man3type" -o "$src_section" = "man3const" -o "$src_section" = "man3head" ]; then
echo "Moving $file to package manpages."
mkdir -p "debian/manpages/usr/share/man/$src_section_strip"
mv "debian/manpages-dev/usr/share/man/$src_section_strip/$file_strip" "debian/manpages/usr/share/man/$src_section_strip/$file_strip"
@@ -64,7 +64,7 @@ for src_section in man*; do
else
# The destination is in the package manpages-dev
# Ensure the source link is not in package manpages
- if [ "$src_section" != "man2" -a "$src_section" != "man3" -a "$src_section" != "man3type" -a "$src_section" != "man3const" ]; then
+ if [ "$src_section" != "man2" -a "$src_section" != "man3" -a "$src_section" != "man3type" -a "$src_section" != "man3const" -a "$src_section" != "man3head" ]; then
echo "Moving $file to package manpages-dev."
mkdir -p "debian/manpages-dev/usr/share/man/$src_section_strip"
mv "debian/manpages/usr/share/man/$src_section_strip/$file_strip" "debian/manpages-dev/usr/share/man/$src_section_strip/$file_strip"
diff --git a/debian/rules b/debian/rules
index 6b3875e8d..ea5118065 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,8 +5,9 @@
override_dh_auto_configure:
# adjust non-standard subsection dir names to FHS:
- sed -i 's/\.so man3type/\.so man3/g' man3type/*
- sed -i 's/\.so man3const/\.so man3/g' man3const/*
+ sed -i 's/\.so man3type/\.so man3/g' man3*/*
+ sed -i 's/\.so man3const/\.so man3/g' man3*/*
+ sed -i 's/\.so man3head/\.so man3/g' man3*/*
override_dh_auto_build:
# Nothing to be done here, we're using a custom installation.