summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Fouces <marcos@debian.org>2022-10-24 00:08:43 +0200
committerMarcos Fouces <marcos@debian.org>2022-10-24 00:08:43 +0200
commit31e78ea80ad33b97b6ec34ea041d9ba7080f112b (patch)
tree4c1967e6ba5d4e5ed0fce19ca631fe638af45242
parentb851722f7dcfa403db0fc8e19d463853ed4b1700 (diff)
Adjust d/move_links_to correct_package to handle non-FHS directories.
-rw-r--r--debian/changelog3
-rw-r--r--debian/move_links_to_correct_package31
2 files changed, 20 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index 83ae588f1..ffc35d964 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,7 +14,8 @@ manpages (6.01-1) UNRELEASED; urgency=medium
manpages package.
* Define --language=C option in dh_installman to avoid *.so suffix
being interpreted as a translation.
- * Update list of files in d/move_links_to_correct_package.
+ * Update list of files in d/move_links_to_correct_package and adjust
+ to handle non-FHS directories and its manual pages.
-- Marcos Fouces <marcos@debian.org> Fri, 21 Oct 2022 22:55:41 +0200
diff --git a/debian/move_links_to_correct_package b/debian/move_links_to_correct_package
index efa72f270..1913e4e48 100644
--- a/debian/move_links_to_correct_package
+++ b/debian/move_links_to_correct_package
@@ -14,10 +14,12 @@ check_breaks_replaces () {
man3/queue.3
man4/console_ioctl.4
man4/tty_ioctl.4
- man3/sigset_t.3type
- man3/sigevent.3type
- man3/sigval.3type
- man3/siginfo_t.3type"
+ man3type/epoll_data.3type
+ man3type/epoll_data_t.3type
+ man3type/sigset_t.3type
+ man3type/sigevent.3type
+ man3type/sigval.3type
+ man3type/siginfo_t.3type"
file_is_known="no"
for file in $known_files; do
if [ "x$1" = "x$file" ]; then
@@ -34,28 +36,31 @@ check_breaks_replaces () {
fi
}
-for src_section in man?; do
+for src_section in man*; do
+ #echo "$orig_section **********************************************************************************************************************"
+ src_section_strip=$(echo $src_section | cut -c 1-4)
for file in $src_section/*; do
destination=`grep "^\.so " $file`
+ file_strip=$(echo $file | xargs basename)
if [ -n "$destination" ]; then
dest_section=`echo "$destination" | sed -e "s/.*\(man.\).*/\1/"`
if [ "$dest_section" != "$src_section" ]; then
- # The destination is in the package manpages
- if [ "$dest_section" != "man2" -a "$dest_section" != "man3" ]; then
+ # The destination is in the package manpages
+ if [ "$dest_section" != "man2" -a "$dest_section" != "man3" -a "$dest_section" != "man3type" ]; then
# Ensure the source link is not in package manpages-dev
- if [ "$src_section" = "man2" -o "$src_section" = "man3" ]; then
+ if [ "$src_section" = "man2" -o "$src_section" = "man3" -o "$src_section" = "man3type" ]; then
echo "Moving $file to package manpages."
- mkdir -p "debian/manpages/usr/share/man/$src_section"
- mv "debian/manpages-dev/usr/share/man/$file" "debian/manpages/usr/share/man/$file"
+ mkdir -p "debian/manpages/usr/share/man/$src_section_strip"
+ mv "debian/manpages-dev/usr/share/man/$src_section_strip/$file_strip" "debian/manpages/usr/share/man/$src_section_strip/$file_strip"
check_breaks_replaces "$file"
fi
else
# The destination is in the package manpages-dev
# Ensure the source link is not in package manpages
- if [ "$src_section" != "man2" -a "$src_section" != "man3" ]; then
+ if [ "$src_section" != "man2" -a "$src_section" != "man3" -a "$src_section" != "man3type" ]; then
echo "Moving $file to package manpages-dev."
- mkdir -p "debian/manpages-dev/usr/share/man/$src_section"
- mv "debian/manpages/usr/share/man/$file" "debian/manpages-dev/usr/share/man/$file"
+ mkdir -p "debian/manpages-dev/usr/share/man/$src_section_strip"
+ mv "debian/manpages/usr/share/man/$src_section_strip/$file_strip" "debian/manpages-dev/usr/share/man/$src_section_strip/$file_strip"
check_breaks_replaces "$file"
fi
fi