summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSylvestre Ledru <sylvestre@debian.org>2013-09-08 11:29:39 +0000
committerSylvestre Ledru <sylvestre@debian.org>2013-09-08 11:29:39 +0000
commit47423cf79c3d4a2d3d4f2e611d95d595c98a314e (patch)
tree12dced4594bf30c7b02a13cefb1a98d5b7783d13
parent090d10c9ac3d535a191c78a6a3b7a77f5f71ea52 (diff)
clang is a mandatory dependency (Closes: #722132)
-rw-r--r--debian/changelog11
-rw-r--r--debian/control27
2 files changed, 38 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..3690d06
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,11 @@
+iwyu (3.3-2) unstable; urgency=low
+
+ * clang is a mandatory dependency (Closes: #722132)
+
+ -- Sylvestre Ledru <sylvestre@debian.org> Sun, 08 Sep 2013 12:33:59 +0200
+
+iwyu (3.3-1) unstable; urgency=low
+
+ * Initial release (Closes: #721267)
+
+ -- Sylvestre Ledru <sylvestre@debian.org> Thu, 29 Aug 2013 17:16:23 +0200
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..cebb1a4
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,27 @@
+Source: iwyu
+Section: devel
+Priority: extra
+Maintainer: LLVM Packaging Team <pkg-llvm-team@lists.alioth.debian.org>
+Uploaders: Sylvestre Ledru <sylvestre@debian.org>
+Build-Depends: debhelper (>= 8.0.0), cmake, libclang-3.3-dev, llvm-3.3-dev,
+ help2man
+Standards-Version: 3.9.4
+Homepage: http://code.google.com/p/include-what-you-use/
+Vcs-Svn: svn://svn.debian.org/svn/pkg-llvm/iwyu/trunk/debian/
+Vcs-Browser: http://svn.debian.org/viewsvn/pkg-llvm/iwyu/trunk/debian/
+
+Package: iwyu
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, clang-3.3 | clang-3.4
+Description: Analyze #includes in C and C++ source files
+ "Include what you use" means this: for every symbol (type, function variable,
+ or macro) that you use in foo.cc, either foo.cc or foo.h should #include a .h
+ file that exports the declaration of that symbol. The include-what-you-use
+ tool is a program that can be built with the clang libraries in order to
+ analyze #includes of source files to find include-what-you-use violations,
+ and suggest fixes for them.
+ .
+ The main goal of include-what-you-use is to remove superfluous #includes.
+ It does this both by figuring out what #includes are not actually needed for
+ this file (for both .cc and .h files), and replacing #includes with
+ forward-declares when possible.