summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSylvestre Ledru <sylvestre@debian.org>2013-08-30 07:46:19 +0000
committerSylvestre Ledru <sylvestre@debian.org>2013-08-30 07:46:19 +0000
commit090d10c9ac3d535a191c78a6a3b7a77f5f71ea52 (patch)
treed52c858884d76b1032e10320197de257b378372d
parent04e2d2da88caf3d27014c073900dbe0b8bbd5a4f (diff)
Improve the manpage
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index bc6a129..f2a8427 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,7 @@
#export DH_VERBOSE=1
TARGET_BUILD=iwyu-build
+VERSION=$(shell dpkg-parsechangelog |grep "^Version:"|sed -e "s|Version: \(.*\)|\1|")
%:
dh $@ --buildsystem=cmake --builddirectory=$(TARGET_BUILD)
@@ -14,5 +15,5 @@ override_dh_auto_configure:
override_dh_auto_build:
dh_auto_build
- help2man $(TARGET_BUILD)/include-what-you-use > $(TARGET_BUILD)/include-what-you-use.1
+ help2man --version-string "$(VERSION)" -n "Analyze #includes in C and C++ source files" $(TARGET_BUILD)/include-what-you-use > $(TARGET_BUILD)/include-what-you-use.1
cd $(TARGET_BUILD) && ln -s include-what-you-use.1 iwyu.1