summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSylvestre Ledru <sylvestre@debian.org>2017-08-03 13:26:32 +0000
committerSylvestre Ledru <sylvestre@debian.org>2017-08-03 13:26:32 +0000
commit54d91a0f73328986bf7afbda1ed4c2696da11529 (patch)
tree30043c5f1e4732c1af21adff8498d6e7b72e988a
parent0ff1309a7b664bc928486d3fb4b636cd9066a03c (diff)
* New upstream release
* Standards-Version updated to 4.0.0 * bump llvm deps to 4.0
-rw-r--r--debian/changelog10
-rw-r--r--debian/compat1
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules2
4 files changed, 14 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index a9aefd5..24a0157 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,16 @@
+iwyu (4.0-1) unstable; urgency=medium
+
+ * New upstream release
+ * Standards-Version updated to 4.0.0
+ * bump llvm deps to 4.0
+
+ -- Sylvestre Ledru <sylvestre@debian.org> Thu, 03 Aug 2017 11:10:20 +0200
+
iwyu (3.9-2) unstable; urgency=medium
* Rebuild to manage clang 3.9.1 (Closes: #849402)
yes, this needs to be properly fixed and managed at runtime
- * Remove usr/bin/fix_includes.py to fix script-with-language-extension
+ * Remove usr/bin/fix_includes.py to fix script-with-language-extension
(was already shipped under fix_includes anyway)
* Rename usr/bin/iwyu_tool.py to usr/bin/iwyu_tool
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..f599e28
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/control b/debian/control
index 28bc65f..1412fe0 100644
--- a/debian/control
+++ b/debian/control
@@ -3,16 +3,16 @@ Section: devel
Priority: extra
Maintainer: LLVM Packaging Team <pkg-llvm-team@lists.alioth.debian.org>
Uploaders: Sylvestre Ledru <sylvestre@debian.org>
-Build-Depends: debhelper (>= 8.0.0), cmake, libclang-3.9-dev, llvm-3.9-dev,
+Build-Depends: debhelper (>= 10.0.0), cmake, libclang-4.0-dev, llvm-4.0-dev,
help2man, libncurses5-dev, zlib1g-dev
-Standards-Version: 3.9.8
+Standards-Version: 4.0.0
Homepage: http://include-what-you-use.org/
Vcs-Svn: svn://svn.debian.org/svn/pkg-llvm/iwyu/trunk/
Vcs-Browser: http://svn.debian.org/viewsvn/pkg-llvm/iwyu/trunk/
Package: iwyu
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, clang-3.5 | clang-3.6 | clang-3.7 | clang-3.8 | clang-3.9 | clang-4.0, python
+Depends: ${shlibs:Depends}, ${misc:Depends}, clang-3.5 | clang-3.6 | clang-3.7 | clang-3.8 | clang-3.9 | clang-4.0 | clang-5.0 | clang-6.0, python
Description: Analyze #includes in C and C++ source files
"Include what you use" means this: for every symbol (type, function variable,
or macro) that you use in foo.cc, either foo.cc or foo.h should #include a .h
diff --git a/debian/rules b/debian/rules
index d6f51f8..4774298 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,7 @@ endif
dh $@ --buildsystem=cmake --builddirectory=$(TARGET_BUILD)
override_dh_auto_configure:
- dh_auto_configure -- -DCMAKE_CXX_FLAGS="$(ADDITIONAL_CXX_FLAGS)" -DLLVM_PATH=/usr/lib/llvm-3.9/
+ dh_auto_configure -- -DCMAKE_CXX_FLAGS="$(ADDITIONAL_CXX_FLAGS)" -DLLVM_PATH=/usr/lib/llvm-4.0/
override_dh_auto_build: