summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSylvestre Ledru <sylvestre@debian.org>2016-11-10 12:21:09 +0000
committerSylvestre Ledru <sylvestre@debian.org>2016-11-10 12:21:09 +0000
commit41aa72d7b7b75d4f92881b543c79ab5d80daac97 (patch)
tree51c3d8b9f22d993a15e6059e303f54c58983d063
parent69aec350ed2b9a0de2ef982fb25922a6c8fdd0bd (diff)
Fix FTBFS on mips64el (Closes: #775435)
Thanks to James Cowgill
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules9
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c96b7ec..2cc73e2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
iwyu (3.9-1) unstable; urgency=medium
* New upstream release
+ * Fix FTBFS on mips64el (Closes: #775435)
+ Thanks to James Cowgill
-- Sylvestre Ledru <sylvestre@debian.org> Thu, 10 Nov 2016 12:49:29 +0100
diff --git a/debian/rules b/debian/rules
index d8bada7..e9fd23f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,12 +6,19 @@
TARGET_BUILD=iwyu-build
VERSION=$(shell dpkg-parsechangelog |grep "^Version:"|sed -e "s|Version: \(.*\)|\1|")
+DEB_BUILD_ARCH?=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
+ADDITIONAL_CXX_FLAGS=""
+
+ifneq (,$(filter $(DEB_BUILD_ARCH),mips64el))
+ ADDITIONAL_CXX_FLAGS += -mxgot
+endif
%:
dh $@ --buildsystem=cmake --builddirectory=$(TARGET_BUILD)
override_dh_auto_configure:
- dh_auto_configure -- -DLLVM_PATH=/usr/lib/llvm-3.9/
+ dh_auto_configure -- -DCMAKE_CXX_FLAGS="$(ADDITIONAL_CXX_FLAGS)" -DLLVM_PATH=/usr/lib/llvm-3.9/
+
override_dh_auto_build:
dh_auto_build