summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSylvestre Ledru <sylvestre@debian.org>2013-08-30 07:18:29 +0000
committerSylvestre Ledru <sylvestre@debian.org>2013-08-30 07:18:29 +0000
commit16ae2dc8d0f44343ed740e81d9b3cf16c5bda55d (patch)
tree052bf55cff10206f306b62777e03b8b3b880c16d
rename of the package
-rw-r--r--debian/copyright35
-rw-r--r--debian/iwyu.manpages2
-rwxr-xr-xdebian/rules17
3 files changed, 54 insertions, 0 deletions
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..6c29835
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,35 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: iwyu (include what you use)
+Upstream-Contact: https://groups.google.com/forum/#!forum/include-what-you-use
+Source: http://code.google.com/p/include-what-you-use/source/checkout
+
+Files: *
+Copyright: Google and others 2010 - 2013
+License: University of Illinois/NCSA Open Source License
+ Permission is hereby granted, free of charge, to any person obtaining a copy of
+ this software and associated documentation files (the "Software"), to deal with
+ the Software without restriction, including without limitation the rights to
+ use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+ of the Software, and to permit persons to whom the Software is furnished to do
+ so, subject to the following conditions:
+ .
+ * Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimers.
+ .
+ * Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimers in the
+ documentation and/or other materials provided with the distribution.
+ .
+ * Neither the names of the LLVM Team, University of Illinois at
+ Urbana-Champaign, nor the names of its contributors may be used to
+ endorse or promote products derived from this Software without specific
+ prior written permission.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ CONTRIBUTORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS WITH THE
+ SOFTWARE.
+
diff --git a/debian/iwyu.manpages b/debian/iwyu.manpages
new file mode 100644
index 0000000..6adbe42
--- /dev/null
+++ b/debian/iwyu.manpages
@@ -0,0 +1,2 @@
+iwyu-build/include-what-you-use.1
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..dc7b2fb
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+TARGET_BUILD=iwyu-build
+
+%:
+ dh $@ --buildsystem=cmake --builddirectory=$(TARGET_BUILD)
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DLLVM_PATH=/usr/lib/llvm-3.3/
+
+override_dh_auto_build:
+ dh_auto_build
+ help2man iwyu-build/include-what-you-use > iwyu-build/include-what-you-use.1